Problem:
There are multiple responses created on the same Survey Question on the same Questions Response record:
Root Cause:
There are two main points to the root cause:
- User accessed a target owned by another: Multiple users/devices working on a single target isn't supported.
- The state of the Target on iPad was where the responses didn't exist: The Target was created online, so the Question Response records would not exist immediately.
Solution:
Filter Targets per user in the Survey Target VMOC to avoid such a situation.
Related Documentation:
CRM Help Documentation: Executing a Survey