Overview:
A survey does not display when an end user selects New Survey Target from the Survey Target related list on the Account page even though the following conditions are true:
- The Survey Publish Apex Veeva Setting is 1
- The user has all required permissions for creating survey targets
- Fields on the survey contain the following values:
- Status_vod: Published_vod
- Open_vod: true
- Channels_vod: CRM_vod
- Assignment_Type_vod: Territory_vod
- The user's assigned territory is included in the Territories_vod field on the survey
- The assigned territory has a unique name
- The account is accessible to the user and aligned to a territory included in the territory assignment
Root Cause:
There are two fields on the Survey_vod object that share the same label:
When the Survey Publish Apex Veeva Setting is equal to 1, the survey is published using the MC Engine and only the Territories_vod field should be populated.
If both the Territory_vod and Territories_vod fields are populated, this is considered a misconfiguration and will result in unexpected behavior.
Solution:
Confirm that only the Territories_vod field is being used. If the Territory_vod is populated, clear this value and republish the survey.
Related Documentation:
CRM Help Documentation: