Overview:
The Survey is not visible when creating from the Survey Target section of the Call Reporting page. However, it is available on the Survey Target selection when creating from the Survey Target related list of Account Classic Page.
Root Cause:
A user has Field Level Security (FLS) to Target_Type_vod for the Survey object.
If the user selects to create a new Survey Target from the Call Report page, the Veeva Setting Enable Child Account is enabled and the Call has a Location value. This skips the target selection and only Surveys which Target_Type_vod equals Child_Accounts_vod display.
If the Call has no Location value, the Surveys which Target_Type_vod_c is blank or Target_Type_vod equals Accounts_vod display.
Solution:
This is currently working as designed.
Under this situation, if the user needs to display the Survey, be sure to set Target_Type_vod as Child_Accounts_vod for the Survey.
Related Documentation:
CRM Help Documentation: Supporting Child Accounts in Surveys