Overview:
In CRM Online, the New button does not appear in My Accounts. The user has Create permission on the Account.
Root Cause:
The issue is caused by the CRM_MANAGED_ACCOUNT_TYPES Network Settings which points to a Veeva Message. If Network is not used and there is a decoupled Data Change Request (DCR), do not modify the Network custom setting section.
Solution:
Be sure that the CRM_MANAGED_ACCOUNT_TYPES Veeva Message has a null value in the Text field.
Related Documentation:
CRM Help Documentation: Enabling Network by Account Record Type