Overview:
Territory Specific Field (TSF) values cannot be edited on Accounts in CRM. A user navigates to an Account and tries to edit TSF values. It produces an error:
[Error extendedErrorDetails='{[0]}' fields='{[0]}' message='insufficient access rights on cross-reference id' statusCode='INSUFFICIENT_ACCESS_ON_CROSS_REFERENCE_ENTITY' ].
Root Cause:
There are two root causes:
- The user does not have access to the TSF_vod Visualforce page.
- Accounts cannot be edited in the User's territory.
Solution:
- Navigate to: Setup --> Develop --> Visualforce Pages.
- Navigate to the TSF_vod Visualforce Page.
- Click on Security.
- Add the User's profile to the Enabled Profiles.
- Click on Save.
- On the User's Detail Page, navigate to Territories.
- Open the Territory and go to Account Access.
- Set to: Users in this territory can view and edit accounts assigned to this territory.
Related Documentation:
CRM Help Documentation: Working with Territory Fields