Overview:
When configuring the Account Hierarchy, the documentation requires changing the Field Type from Master-Detail to Lookup. However, the Change Field Type button is not available. The user is unable to change the field type for Parent_Account_vod__c on the Child_Account_vod__c object.
Root Cause:
If the Change Field Type button does not appear, it is an indication that the field is referenced by another process (Apex code, VisualForce Page, Workflow, etc.).
Solution:
Review processes to determine the reference to Parent_Account_vod__c and remove it.
Related Documentation:
Salesforce Documentation: Notes on Changing Custom Field Types
CRM Help Documentation: Account Hierarchy