Overview:
The Follow-up Activities is not available as a related list in the Account Detail page in the offline (iPad) version to create a task.
Root Cause:
Follow-up Activities are stored as standard SFDC Tasks and are not supported Offline as a related list on the Account Detail page.
Solution:
Once a user logs into CRM for iPad, assigned tasks can be viewed on the VMobile Home Page.
Tasks can be created Offline using Follow-Up Activities from a Call.
Related Documentation:
CRM Help Documentation: Creating Follow-up Activities on the Call Report