Overview:
When attempting to submit a Call, a user received the error message "A detailed product must be selected in order to submit the call." However, no Detail Products are available for the user to add to the Call.
Root Cause:
One potential cause for this issue is that the Call2_vod Page Layout being used includes the "--sd --so" section signals on the section containing zvod_Detailing_vod.
These section signals, when used together, prevent the Product Detailing from being updated after a Signature has been captured on a Call Report.
Solution:
Remove the --sd --so section signals from the relevant section of the Call Report to allow users to update the Product Detailing, therefore meeting this requirement for submitting Calls.
Related Documentation:
CRM Help Documentation: Detailing Products on the Call Report