Overview:
A Call report only displays the Health Care Professional (HCP)'s name rather than the combination of the Health Care Organization (HCO) and the Health Care Professional (HCP) when the end-user creates a Call report through the Call cycles function.
Assumption:
- Child Account is enabled in the organization
- There is an HCP who works in two hospitals:
- Hospital A: Primary = Yes
- Hospital B: Primary = No
Operation:
- Click Call Cycles --> View Call Cycles in the My Schedule page.
- Drag and drop a child account that works in Hospital B to the calendar.
Problem:
The Call report only displays the HCP's name, and it does not display the HCO's name.
Root Cause:
One possible reason is the end-user does not have Edit permission to the Call_Cycle_Entry_vod__c.Child_Account_vod__c field.
Solution:
Grant Edit permission to the Call_Cycle_Entry_vod__c.Child_Account_vod__c field by using the following the steps:
- Navigate to: Setup --> Manage Users --> Users.
- Select the relevant profile.
- Navigate to Field-Level Security --> Call Cycle Entry --> View.
- Click the Edit button.
- Check the checkbox of the Edit Access for Child Account.
- Save the change.
Related Documentation:
CRM Help Documentation: Managing Call Cycles