Overview:
The Call Location feature is configured (ENABLE_MYSCHEDULE_CALL_LOCATION Veeva Setting = true). When recording a Call against a Person's Account, the Address field is not populated. Despite the fact that Controlled Address is enabled on the Person Account's Address record and Controlling Address is pointing to Business Account's Address.
Root Cause:
The user does not have Read and Edit permissions to the following Address object fields:
- Controlled_Address_vod__c
- Controlling_Address_vod__c
Solution:
Provide Read and Edit permissions to the required fields using Field-Level Security (FLS).
Related Documentation:
CRM Help Documentation: Selecting the Call Location