Overview:
On a Child Call for a Group Call in Veeva CRM, the Account_vod__c field is not populating with the ID of the Account that the Call was recorded against.
Root Cause:
This is occurring because the Child Call is on a User Attendee, and is working as designed.
Solution:
When a Group call is created that has Users as Attendees, the Account_vod__c will not populate on the Child Calls against those Users.
Related Documentation:
CRM Help Documentation: Capturing Unique Information on Group Call Attendees