Overview:
When the Rep User tries to record a call against a Person Account, no address is available, however, there are addresses related to both the Person and on the parent Business Account. The ENABLE_MYSCHEDULE_CALL_LOCATION Veeva setting is set to true and zvod_Business_Account_vod is used on the Call page layout.
Root Cause:
The Person Account's address is not controlled by the address of the Business Account. The ENABLE_MYSCHEDULE_CALL_LOCATION Veeva setting creates a dependent relationship between the Business Account selected in the zvod_Business_Account_vod (Location) field on a Call to a Person Account and the addresses available for selection in the Address field. When enabled, addresses displayed in the Address picklist are filtered to only include those that are controlled by an address belonging to the Business Account selected in the Location field.
Solution:
Related Documentation:
CRM Help Documentation: Selecting the Call Location