Overview:
The General Key Message is not appearing as a selection on a Call that is assigned a Detail Group.
Root Cause:
Visibility to Key Messages are driven by the Product_vod__c field on the Key Message.
Solution:
A Key Message's visibility on a Call report is based on the Product field and the Products that are selected in the user MySetup. If the Product is assigned to a Group, the Group, as well as the Product, need to be specified on the Key Message. Key Messages are not made available by Detail Group without assigning a Product on the Key Message and having the User detail the Product on the Call page.
Related Documentation:
CRM Help Documentation: Using Key Messages on the Call Report