Overview:
When performing a sync with the Veeva CRM Offline, a user receives an error in the Activity log:
No such column (Field API Name) on entity (Object API Name).
On the iPad, the following error messages might appear for the user: "Sync Failed" or "Update Failed"
Root Cause:
The error occurs due to an invalid configuration. The user, who performs synchronization, does not have access to the field on the object listed.
Solution:
Provide the user Read access to the field listed in the activity log at the Profile level or through Permission Sets.
Related Documentation:
CRM Knowledge Article: Error: No such column - Continuously Occurs With Different Fields on CRM Offline