Overview:
An sync error continuously occurs on a users offline device with different fields the user already has access to. The error fails the sync and displays as: "No such column."
Root Cause:
This occurs when the org is using Permission Sets to grant access to specified objects and fields, but Permission Sets are not enabled properly for this user.
The user could be missing the Apex Class: VeevaUserPermissions.
Solution:
To resolve the error, follow these steps to configure Permission Sets:
- Navigate to the Apex Class VeevaUserPermissions. (Setup>App Setup>Develop>Apex Class.)
- Enable profile access to the Apex Class VeevaUserPermissions.
- Click Security.
- Select all profiles under Available Profiles . It is important to select all profiles, regardless of whether they have Permission Sets defined, in order to avoid future configuration inconsistencies.
- Click Add to move them to Enabled Profiles.
- Click Save.
Note: Users must have VeevaUserPermissions Apex Class Access allocated at the profile level rather than through a permission set.
Related Documentation:
- CRM Knowledge Base Article: Error: No such column (Field_vod__c) on entity (Object_vod__c) - When Performing Veeva CRM Synchronization
- CRM Help Documentation: Implementing Security in Veeva CRM