Overview:
The user is not able to log in CRM Windows and cannot Sync, Error: Refresh unsuccessful occurs.
Then stuck on Checking for new data ...
Root Cause:
This is because the user has no access to WinModern_vod device VMOCs.
The Sharing Settings of VMOC object is set as Private in the org and not shared with the user properly:
Solution:
Adjust the Sharing Settings to share WinModern_vod device VMOCs with the user.
Salesforce document: Sharing Settings
Related Documentation:
CRM Help Documentation: N/A