Problem:
After connecting a CRM integration user with valid credentials on an integration tab (i.e.: Approved Email, CLM) and clicking the Validate option on the connection it shows a "Credentials Are Invalid" message despite the valid credentials.
Root Cause:
The password of the integration user may contain a non-ASCII character.
Solution:
Remove/replace the non-ASCII character from the integration user's password.
Related Documentation:
Salesforce Documentation: Set Password Policies