Overview:
When recording a new call and clicking the Start Media option an error message appears:
This account has not been validated. It is not possible to record a call against it.
Root Cause:
The CRM org has Child Accounts enabled and the Parent Account has Do_Not_Call_vod__c set to Yes_vod.
Solution:
Change the Parent Account's Do_Not_Call_vod__c field's value to No_vod.
Related Documentation:
CRM Help Documentation: