Overview:
Links from Approved Emails are opening to an error page that states something similar to:
Your connection is not private
Attackers might be trying to steal your information from <domain>
The error page also shows an error code of NET::ERR_CERT_COMMON_NAME_INVALID
The specifics of the error may differ by platform and browser, but here is an example from Chrome:
When this issue occurs, all links from an Approved Email open to the same error page.
Root Cause:
This issue can be caused by an invalid security certificate on the Click Tracking domain created for a customer's Approved Email sending domain.
In Approved Email, all links are wrapped with a Click Tracking link that first sends the click to the Click Tracking domain to record the recipient's click. Then, the Click Tracking domain forwards the reader to the target link. This is an industry standard for tracking clicks in email.
If the Click Tracking domain's security certificate is missing or invalid, this can cause the error shown in the image above.
Solution:
When encountering this error, please open a Support Ticket with Veeva Product Support, and provide a screenshot of the error or the name of the domain listed in the error message.
Product Support will then work with internal resources to have the Click Tracking domain's security certificate regenerated.
Once the certificate is regenerated, links in email will begin working again - both in emails already sent, and any newly sent emails. There is no need to re-send the emails where the error was found, because once the certificate is corrected, links in those emails will no longer encounter the error.
Related Documentation:
CRM Help Documentation: How to Open a Ticket with Veeva Product Support?