Problem:
When assigning an existing Call (Account and Parent Account = parent and child Call) to a presentation, an error message is thrown to the user:
Accounts on this call cannot view this presentation: <parent account name>
Root Cause:
There is a record type restriction in the background.
The restriction can be done in two ways in general:
- The available Call Record Types are related to the user who is performing the steps.
- The allowed Call Record Types are controlling which Account can have calls of which record type
In case not having any common then an error is expected as either the user or the account cannot have the record type that would be assigned to the calls after the presentation connection.
Example:
- ParentCall with Account1 and ChildCall with Account2 >> Call
- User1 available Call record types: RC_1 , RC_2
- User2 available Call record types: RC_1 , RC_2 , RC_3
- Allowed Call Record Types (via ALLOWED_CALL_RECORD_TYPES Veeva Message):
Account1,RC_1,RC_3;;Account2,RC_3;;
When User1 assigns the presentation to the Call then the error is expected as Account2 from the ChildCall can only have RC_3 as call record type but it is not available for User1.
When User2 assigns the presentation to the Call then no error occurs.
Solution:
Make sure that there is at least one record type in the intersection of
- the user's available Call Record Types
and - the accounts' Allowed Call Record Types from the assigned Call records (via ALLOWED_CALL_RECORD_TYPES Veeva Message)
Related Documentation:
Online Help Documentation: Restricting Calls by Account Record Type