Overview:
Multichannel Cycle Plan (MCCP) Integration does not Update Last Activity Date in CRM
Root Cause:
Team-Based Goals are enabled by permissions.
The integration user has Field Level Security (FLS) Edit access to the MCCP Team fields. However, the user does not have FLS Edit access to the Team_Last_Activity_Datetime_vod and Team_Last_Activity_Date_vod fields on the MC_Cycle_Plan_Channel_vod and MC_Cycle_Plan_Product_vod.
Solution:
Grant MCCP Integration users FLS edit permission to all of the following fields on the MC_Cycle_Plan_Channel_vod and MC_Cycle_Plan_Product_vod objects.
- Last_Activity_Datetime_vod
- Last_Activity_Date_vod
- Team_Last_Activity_Datetime_vod
- Team_Last_Activity_Date_vod
Related Documentation:
CRM Help Documentation: Displaying the Last Activity Date for Each Channel and Product
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.