Overview:
The Detailing Priority is enabled on the Multichannel Cycle Plan (MCCP) Target. There are submitted Calls with certain Detail Products where not all of them are calculated in the Product Activity Actual field in the MC Cycle Plan Product Record.
Root Cause:
The query to count the product activities from the Call2_Detail_vod object must match both the Product and the Detail Priority values from the MC_Cycle_Plan_Product_vod record.
If the Detail_Priority_vod__c field value on the Call2_Detail_vod object is different than the value of the same field on the MC_Cycle_Plan_Product_vod__c object, the Product Activity is not counted.
Solution:
Be sure that the Detailing Position of the concerned Product on the Call Report matches the number value of the Detail_Priority_vod__c field on the MC_Cycle_Plan_Product_vod__c object.
Related Documentation:
CRM Help Documentation: Detailing Priority on the MCCP Target