Overview:
Why are calls not calculated into MCCP in Veeva CRM, even if the calls match the Cycle Channel Criteria? Another indication of the error is that the MC Cycle data is not calculated at all.
Root Cause:
1. The value(s) of the Status_vod__c field of the MC Cycle Plan Target(s) is not Active_vod.
The MCCP calculation job looks for the Active_vod value.
2. The value of the Status_vod__c field of the Multichannel Cycle Plans (MCCPs) does not match the API name of the available picklist items. For example, its value is In Progress instead of In_Progress_vod.
3. The value(s) of the Status_vod__c field of the Multichannel Cycle (MC Cycle) does not match the API name of the available picklist items. For example, its value is In Progress instead of In_Progress_vod.
The reason may be caused by an incorrectly performed data load, incorrectly set up custom solution (Such as an Apex job), or custom integration process.
4. The Territory_vod__c value of the Call must match with the MCCP's Territory_vod__c value, moreover it must match with any of MCCP's Owner's Territory and any of the related MCCP Target Account's Territory.
5. The Account_vod__c value of the Call record does not match with the related MCCP Target's Target_vod__c value.
6. The Owner of the Call does not match with the Owner of the MCCP.
7. The Call's Call_Date_vod__c value is not between the MCCP's Start_Date_vod__c and End_Date_vod__c value.
8. The MC Cycle Channel record that is associated with the MCCP Channel is not the same as the MCCP's Parent MC Cycle's MC Cycle Channel record. It can happen due to a bad data load.
9. When an MCCP calculation job fails, which is related to the MCCP, the Calls also do not get calculated.
10. The related MCCP Channel's Channel Activity Max value caps the Interactions value, hence the Call does not get considered in the Interaction value.
Solution:
1. Make sure that the value of the Status_vod__c field of the MC Cycle Plan Target is Active_vod.
2.-3. Make sure that the API names match.
4. Make sure that the Call's Territory value matches with the MCCP's Territory value and that the Owner of the MCCP and the MCCP Target Account also have this Territory assigned to them.
5. Make sure that the values match.
6. Make sure that the Owner for both records are the same.
7. The Call's Call Date value must be between the MCCP's Start and End Date, otherwise the call does not get calculated.
8. Make sure there is no mismatch related to MC Cycle Channel(s).
9. Make sure to correct the errors, for more information please check the following article: How to Handle a Processing Error in Multichannel Cycle Plan Admin Console in CRM Online?
10. You can adjust the Channel Activity Max value to reflect newer calls in the Interaction values: What are the Purposes of the Channel Activity Max and Product Activity Max Fields in the Veeva CRM MCCP Functionality?
Related Documentation:
CRM Help Documentation:
Knowledge Article:
- What Date is Considered for Each MCCP Channel Object During the MCCP Calculation Job in Veeva CRM?
- How to Handle a Processing Error in Multichannel Cycle Plan Admin Console in CRM Online?
- Veeva CRM MCCP Admin Job Error: UNABLE_TO_LOCK_ROW: unable to obtain exclusive access to this record or x records
- What are the Purposes of the Channel Activity Max and Product Activity Max Fields in the Veeva CRM MCCP Functionality?