Overview:
When the user tries to publish a Survey, it remains in Publishing_vod status.
Generally, once a Survey is ready to be pushed to the field, the Survey Designer can publish it.
Clicking Publish triggers the batch referenced in the Survey Publish Apex Veeva Setting. Out of the box, the triggered batch is the VEEVA_BATCH_SURVEY_PUBLISH Apex Class.
Root Cause:
The Territories_vod field is placed on the Survey_vod page layout. This is only supported when using the Veeva MC Engine to publish Surveys.
The integration user’s credentials are invalid. This user is used to write back data to the SFDC database after a Survey is published.
Solution:
The following method is used for Survey publishing:
- If the Survey Publish Apex Veeva Setting is blank, Surveys are published using the VEEVA_BATCH_SURVEY_PUBLISH Veeva Apex class.
- If the Veeva Setting is filled with a different Apex class name, Surveys are publishing with the named Apex class.
- If the Veeva Setting = 1, Surveys are published using MC Engine.
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Enter valid credentials for the integration user on the Survey Administration tab. To do so, follow these steps:
- As a System Administrator, go to the Survey Administration tab.
- Click Edit in the Salesforce Credentials section.
- Enter credentials for the integration user.
- Click Save.
- Click Validate credentials in the Salesforce Credentials section.
- If the credentials are valid, the following message appears:
Note: if Territories_vod is being used (it is on the Survey_vod page layout) and the Veeva Setting is blank, the system attempts to publish using the MC Engine.
Related Documentation:
CRM Help Documentation: Publishing a Survey