Overview:
Accounts outside the user's Territory have their icons displayed in grey under the Hierarchy tab in My Accounts Offline. It is possible to add them to the user's Territory using the Add Account button (+).
However, when trying to add out of Territory Accounts, the + button does not appear for the User.
Root Cause:
For Child Account-enabled orgs this option is not available from the Hierarchy tab. Users need to add the Parent and the Child Accounts separately.
Solution:
If the user expects to see the Add Account button in CRM for iPad, the Enable Child Account Veeva Setting needs to be disabled.
Related Documentation:
CRM Help Documentation: Working with Child Accounts