Overview:
Unexpected Remove Account red dash signs (red minus/hyphen) displaying next to particular accounts in the Future Territory Alignments Tab of Veeva Align. There is no Remove Account challenge associated to the Accounts. The account may or may not be a Target.
Root Cause:
As the legend - Accessed via the Information icon on the top left screen - of the Future Alignment Tabs states - This account will be removed from your territory. This means that the Account is going to be removed from the Model Territory after publishing the Project. In the event this is not expected, it is considered a misconfiguration.
There are several causes of this misconfiguration:
- The Planned Publish Date Time of the Project is not in between the Start Date Time and End Date Time of the Model Account Territory of the associated Account.
- The account is not assigned to the Model Territory but it is assigned to the Production/Live Territory.
- There is a related Model Account Exclusion record with the type of Account.
- The Send to CRM value of the Model Account Territory is False.
- The source of the Model Account Territory record is CRM Feedback. In this case, the behavior is currently expected.
Solution:
I. In the event of the first scenario, Ensure that the relevant Date Times are adjusted accordingly to the Model Account Territories or the Project.
II. Ensure to adjust the assignment or have a Keep Account Challenge action executed in the Future Territory Alignments tab.
III. Ensure to adjust the related Model Account Exclusion record.
IV. Be sure to change Send to CRM to True in case the assignment is intended to be pushed into CRM after Project Publishing.
V. Change the source from CRM Feedback (crm_feedback__aln) to Import. (import__aln).
In any of these cases, after making any changes, running Recalculate Territory Data is necessary on the appropriate Modeling Field Force.
- The Recalculate Territory Data process may take a longer time to complete. It can take up to one hour.
- The presented data is not customer specific.
Related Documentation:
Align Help Documentation: