Overview:
Product Metrics Related Fields and Data are not Displayed in the Veeva Align Territory Feedback Functionality in Veeva CRM The scenario applies both Feedback modes, the online and offline platforms.
Root Cause:
The issue may be caused by the fact that while there are Product Metric records associated between the Accounts and Products, the Current/Active Model Territory Product records are missing between the Territories and Products in the affected Modeling Project.
In order for Product Metrics to appear in the Feedback functionality in Veeva CRM, the current/active Model Territory Product records are required to exist.
Solution:
Create the necessary Model Territory Products in the Modeling Project, and Run Recalculate Territory Data on the Modeling Field Force.
- The Model Territory Products can be created in several ways, by Data load, Align UI, by Field Force Products - Inheritance, or directly importing them from the Production (Live) environment.
- A potential cause of the Model Territory Products missing is the fact that Field Force Territory Product inheritance is not enabled. Be sure to check if it is enabled in the Model Align Setting, and Production Align Setting records.
Related Documentation:
Align Help Documentation: