Overview:
The duration field of the Call Key Message Records is blank in Veeva CRM.
The behavior can be reproduced in the following way:
- Create a Call with the end-user and submit it on the offline device.
- Unlock the Call record with the Local Admin in the online environment.
- Resubmit the Call with the end-user on the offline device.
Root Cause:
The Local Admin does not have Field Level Security (FLS) Edit on all the relevant fields.
Solution:
Grant Edit FLS to all of the Call Key Message fields to the Local Admin.
Related Documentation:
CRM Help Documentation: