Overview:
The Veeva CRM Counterpart of the Key Message (Slide) in the Superseded State in Vault does not Get Expired in Veeva CRM if the Succeeding Key Message (Slide) Version is Expired in Veeva Vault. Why does this happen?
Root Cause:
The issue is caused by a misconfiguration in Vault. The Obsolete State of the CRM Content Lifecycle state is not populated with the value of Expired. In the following screenshot, it can be seen as populated.
This value needs to be populated with the Expired value, otherwise, the CRM-Vault Integration is not able to recognize if the Slide is expired or not.
Note: The Obsolete State must be populated with Expired on the Binder Lifecycle and Approved Email as well.
Solution:
- Populate the Obsolete State with the value of Expired.
- Run the CRM-Vault Integration-related processes.
Related Documentation:
CRM Help Documentation: