Overview:
Key Messages are lost in Call Key Messages after syncing to CRM Online when the number of Call Key Messages is greater than 25.
Root Cause:
The user does not have Edit Field-Level Security (FLS) to the Entity_Reference_KM_Id_vod__c field of Call Key Message.
Currently, when the number of Call Key Messages is greater than 25, if the user has Edit FLS on the Entity_Reference_KM_Id_vod__c field, the app saves the Key Message ID into that field. Then when the record is synced up, a trigger on Call2_Key_Message_vod__c sets the Key_Message_vod__c field according to the value of the Entity_Reference_KM_Id_vod__c field.
Solution:
Grant Edit FLS to Entity_Reference_KM_Id_vod__c of Call Key Message when the number of Call Key Messages is greater than 25.
Please refer to this guide if needed: Field-Level Security
Related Documentation:
CRM Help Documentation: Tracking CLM Key Messages