Overview:
Error message: A signature or a sample card number is required to submit a call with a sample.
If the --nslns section signal is not added on the Call page layout, this error message is only displayed when submitting a Sample Call. However, the error occurs when saving a Sample Call in CRM.
Root Cause:
It is because the Enable Samples On Save in Veeva Settings is enabled.
Solution:
If needed, deselect the Enable Samples On Save in Veeva Settings.
Related Documentation:
CRM Help Documentation: Section Signals