Overview:
BRC products are missing from the Samples section when editing a call in iRep while they are available online.
Root Cause:
This can be caused by the --nb section signal.
This section signal ensures that no BRC/Sample Request product catalog records are displayed under the Samples section.
If this is removed from the Samples section's header, but kept in the name of any other layout section, it will still hide the BRC products in iRep.
In CRM Online, it is enough to ensure that this section signal is not present in the Samples section's header in order to avoid this issue.
Solution:
Be sure that the --nb section signal is not added to any sections in the call page layout.
Related Documentation:
CRM Documentation: Section Signals