Overview:
When trying to submit a call Online that has Samples recorded, the Submit button is not responding after clicking on it.
Root Cause:
The call has a Promotional Item and the Company Product checkbox is unselected for the Product.
Solution:
The Company Product checkbox must be selected on both the parent product record and the child product record in order to be available for Call Sampling.
Note: This issue is not happening Offline, because the Company Product checkbox is not validated when Submitting a Call Offline.
Related Documentation:
CRM Help Documentation: Configuring Products for Call Sampling