Overview:
While attempting to Sync or Full Refresh the CLM Administration Console, the following error is returned:
Failed to get CLM Presentation and Slides from Salesforce DB! Cause: Slide XXXXXXXXXXXXXXXXXX no longer has a key message. Please delete this slide and do a full refresh. |
The associated CLM Presentation Slide (ID XXXXXXXXXXXXXXXXXX) has a Key Message record defined.
Root Cause:
This error message can occur in two situations. When the CLM Presentation Slide no longer has a Key Message record defined or the Veeva External ID (VExternal_ID_vod__c) fields on the CLM Presentation Slide and Key Message do not match.
- For Vault content, the VExternal_ID_vod__c field should never be manually modified.
- For non-Vault content, the VExternal_ID_vod__c should not be used.
The VExternal_ID_vod__c fields are used for Vault to CRM integrations and should not be populated for non-Vault hosted content.
Solution:
For Vault content, delete the CLM Presentation Slides that receive the errors. The CLM Admin integration recreates the slides as necessary.
For non-Vault content, remove the value in the VExternal_ID_vod__c fields on the Key Message and CLM Presentation Slide records.
Related Documentation:
CRM Help Documentation: N/A