Overview:
After syncing in Veeva CRM Offline, an error occurs: Insufficient access rights on cross-reference id:xxxxxxxxxxxxxxxxxx.
Root Cause:
The error is caused when updating a Call, the cross-reference id refers to the associated object (For example, Key Message, Call_ClickStream, etc) is either deleted or the access is removed from the user.
Solution:
If the user lost access to the related object, do the following:
- Provide temporary access.
- Perform a sync on the call.
- Undelete the object.
- Perform a sync.
- Delete the object once the user confirms the error is resolved.
If the object is hard deleted (not in the recycle bin), the call may not be fully recovered. do the following:
- Retrieve the VTrans folder from the user.
- Open a ticket with Veeva Support
- Provide the user information and activity logs.
- Support investigates the error further to see if the call can be recovered.
Related Documentation:
CRM Knowledge Article:
Send us your feedback: We're always looking for advice to help improve our Knowledge Base! Please let us know if this article was helpful or provide feedback on how we can improve your experience here.