Overview:
When a user creates a new Order and clicks Save, an error is returned: This Account is not allowed to create orders.
Root Cause:
The Default_Order_Type_vod__c and Order_Type_vod__c fields on the Account record are required to have values present to submit an Order. These fields are left blank on the initial implementation and are not updated automatically when Order Management is implemented in an existing org.
Solution:
Populate Default_Order_Type_vod__c and Order_Type_vod__c on each Account record that is allowed to have an Order submitted on its behalf.
Related Documentation:
CRM Help Documentation: