Overview:
Clicking on the Edit_DCR_vod button leads the user to the simple Edit page, not the Edit Data Change Request (DCR) page if the Data Change Request Mode setting is set to 0.
However, in the case of the New_Address_DCR and the New_Child Account_DCR buttons, the user receives an error message: You do not have permission to create Data Change Request on this record. Please contact your system administrator as shown below:
There seem to be different processes when using these buttons.
Root Cause:
Unlike the Edit_DCR_vod button, the New_Address_DCR and the New_Child Account_DCR buttons rely on having permission to the correct objects and do not redirect the user to the New Address or New Child Account pages. Therefore, access is being denied for the given user/profile combination - the page is working as designed for the current configuration.
Solution:
If the user does not wish to use the DCR process, a separate Page Layout needs to be created that contains the standard New buttons for the Address and Child Account objects.
If the user would like to use the DCR process, ensure the correct DCR-related Custom settings and Network Settings are configured for the given profile. Please note that custom settings can be set at the profile level, and a given profile may not be utilizing the organization-wide custom settings.
Related Documentation:
CRM Help Documentation: