Overview:
Users receive an error in CRM Online when navigating to a new page: Insufficient Privileges.
Root Cause:
The page the user is navigating to is trying to open a Visualforce Page but does not have the Visualforce Page Access Enabled.
For example:
- The user receives an error while clicking the Capture Consent button from an Account.
- The URL appears as: https://c.cs1.visual.force.com/apex/Consent_Capture_vod?...
- The Visualforce page that is being opened is after the /apex/...
- The user needs access to Consent_Capture_vod Visualforce page.
Solution:
Enable Visualforce Page Access to the page the user needs access to.
- Open the user profile.
- Navigate to: Setup --> Manage Users Profiles --> Select a profile --> Enabled Visualforce Page Access --> Edit.
- Enable the Specific Visualforce Page.
Related Documentation:
CRM Help Documentation: Visualforce Page Sections