Overview:
When assigning a permission set to a user in CRM Online, the following error message appears:
Can't assign permission set [Permission Set Name] to user [Username]. The user license doesn't allow the permission: [Permission Name]
Root Cause:
The affected user is assigned to a Salesforce Platform license. The permission set is not intended to function with the Salesforce Platform license. Therefore, it is not possible to assign this permission set to any user with this license.
Solution:
A user with the Salesforce license, rather than a Salesforce Platform license, should allow for the permission set to be assigned.
To eliminate the error, follow these steps:
- Identify the concerned access from the error message (e.g. Read access to the Products object in this instance).
- Remove the access from the Permission Set.
- Assign the permission set to the user.
Related Documentation:
Salesforce Help Documentation: Permission Sets