Overview:
An end-user receives the following error during the synchronization:
Error message: VOD_CALL2_AFTER_INSERT_TRIGGER: execution of AfterInsert caused by: System.StringException: Invalid id: ;a0D2400000XXXx1XXX Caused by Trigger VOD_CALL2_AFTER_INSERT_TRIGGER
Note: a0D2400000XXXx1XXX is substituted with the Salesforce ID of a Key Message record.
Root Cause:
Veeva CRM for offline devices registers Key Message records related to the Call in the Add_Key_Message_vod field separated by triple semicolons.
The VOD_CALL2_AFTER_INSERT_TRIGGER parses the field and creates the Call Key Message records based on the value of this field. If the name of any of the added Key Messages ends with a semicolon, the parsing fails.
Note: the Key Message causing the error is not the same as the record indicated in the error message. All Key Messages added by the end-user should be analyzed.
Solution:
Open a ticket with Veeva Support to fix the Call data.
To prevent future occurrences remove the semicolon from the end of the Key Message Name and perform a sync Offline.
Related Documentation: