Overview:
When updating the Address Name in CRM, an error occurs:
Address cannot be updated.
Root Cause:
There are two possible reasons for this error:
- The address is locked and the user is not a System Administrator
- The address is a Controlled Address
Solution:
For Locked Addresses:
- If the Locked field is set to true, only users with the Modify All Data privilege can edit the Address Line 1(Name) field or delete the record.
- If the Locked field is null, false or absent, then the trigger should do nothing. The Locked field is best left off of the Rep Maintained layouts.
- The Address trigger, preventing users to modify the Address, is VOD_ADDRESS_VOD_BEFORE. Support does not recommend changing it as it could be overwritten in future releases.
Note: This is concerning the Modify All Data from Administrative Permissions (not Modify All from Address Object Permissions). If this is an integration user, it results in the same error when trying to update from Dataloader or other tools as well.
For Controlled Addresses:
- Update the Name from the Controlling Address or remove the Controlled Address information to change only that address.
Related Documentation:
CRM Help Documentation: Network Address Inheritance Support