Overview:
A user is receiving an error when saving a record: [Object]: bad field names on insert/update call: [Field]
Example:
A user tries to submit a Call and receives the error: Call2_vod__c: bad field names on insert or update call: Status_vod__c.
Root Cause:
The user does not have access to the Field.
Solution:
To provide Field Level Security (FLS) to the user, follow these steps:
- Log into the Org as a System Administrator.
- Navigate to: User --> User Detail.
- Drill into the Profile.
- Go to the Field-Level Security section.
- Click [View] next to the Object.
- Click Edit.
- Check Read Access next to the Field.
- Select Save.
- Clear the Veeva Cache.
Related Documentation:
N/A