Overview:
A HealthCare Provider (HCP) is trying to access a Survey which is part of an Approved email. When the HCP accesses the survey, the browser is redirected to a page which displays the message: This site can't be reached.
Root Cause:
The {{surveyLink}} token determines which Survey to display in the iFrame based on the approved_document_vod__r.survey_vod__c field. If the Approved Email Admin does not have access to this field or if the field is not populated with the correct SFDC ID, then this page displays.
Solution:
There are a few things to check when this error occurs:
- Ensure the Approved Email Admin has read access to the approved_document_vod__r.survey_vod__c field.
- Ensure the end-user has read access to the approved_document_vod__r.survey_vod__c field.
- Ensure the approved_document_vod__r.survey_vod__c field is populated with a survey that is published using the Multichannel Engine.
- If the approved_document_vod__r.survey_vod__c field is blank, ensure it is being populated either manually or using the CRM and Vault Integration for Approved Email.
Related Documentation:
CRM Help Documentation: Surveys in Approved Email