Overview:
The end user is receiving the following error on the Send Email Page: The [Account name] is not Opted to Receive Emails for Approved Email.
Root Cause:
There are two scenarios when this error occurs:
- There is no Multichannel Consent Opt-in record associated with the Account
- The end user has no access to the Content Type lookup field on the Approved Document object
Solution:
First Scenario: Be sure that there is a valid Opt-In record associated with the Account.
Second Scenario: Be sure to provide the end user access with at least read Field Level Security (FLS) to the Content Type lookup field on the Approved Document Object.
Related Documentation:
CRM Help Documentation:
- Consent Capture Overview
- Capture Consent for Content Type
- Managing Approved Email Consent for Accounts