Overview:
A user attempts to submit a Call, but receives the following error message: Required fields are missing: Lot_vod__c.
Sample limit records are created or updated for a saved Call in the online CRM environment. The Enable Samples On Save Veeva Setting is disabled.
Root Cause:
The error occurs because the name of the Sample Product record or the Sample Lot record Sample value is changed after the user added the sample. Because of an incorrect configuration, the submit action is interrupted. The Sample Limit records are updated but the Call is not submitted.
Solution:
In order to resolve the issue, the Sample_vod__c field on the Sample_Lot_vod__c record must be matched with the name of the related Sample type Product_vod__c record.
Related Documentation:
- CRM Help Documentation: Creating Sample and Product Limits