Problem:
A user receives an error when sycning CRM on an iPad:
Exceeded 100000 distinct ids.
Root Cause:
The query returns too many results, hitting a Salesforce query limit.
Some queries, when run by a user without View All Data permission, require checking Sharing Rules if many records are returned.
This includes queries on objects that use a polymorphic foreign key, such as Task or Attachment.
Such queries return this exception because the operation requires too many resources.
Solution:
Update the Where clause on the VMobile Object Configuration (VMOC) for the object to narrow the scope of the data downloaded.
Related Documentation:
Salesforce Help Documentation:
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