Overview:
An end-user receives an error when trying to Capture Consent which is linked to a Content Type: Bad Request. The user can close the Consent Header as usual, but no Multichannel Consent record is created and the consent changes are not saved.
Root Cause:
The end-user is missing My Setup or SFDC sharing access to the Product record associated with the Consent Line that is being modified.
Solution:
A. Grant My Setup Access:
- Open the My Setup tab.
- Enter the user's name.
- Click Edit.
- Enable (add a check in the box) next to the required Product.
- Click Save.
B. If My Setup access is already granted, but the user is still missing access to the particular Product record, verify the SFDC sharing setting of the Product_vod object records:
- Go to Setup --> Administration Setup --> Security Controls --> Sharing Settings.
- Select the Product Catalog value from the picklist next to Manage sharing settings for.
- On the next page change the org-wide settings or create a sharing rule.
Related Documentation:
CRM Help Documentation: Capture Consent for Content Type
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