Overview:
The user defines Product Metrics, Detail Group and Metrics Configuration. An error displays under the Detail Group in Ratings and Evaluations of the CRM Account: There are no metrics currently selected for the Ratings Control.
Root Cause:
The following items may be root causes of this error:
- The product is not assigned to the user.
- The user has no Field Level Security (FLS) permission to the Detail Group field of the Metrics Configuration object.
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The Product Group and Detail Groups are set up incorrectly - this can happen when the Detail Groups/Topics are not tied properly to Product Groups.
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The Record Type Label for the Account Type that a Metric is tied to is not set up properly. For example, if the user sets up a Product Metric to be tied to Hospital_vod (API Name) Accounts. While the UI ties the Product Metric to the Account Type by API Name, the Product Metric does not work unless the API Name and the Record Label name for the Account Type match exactly.
- The user has no Read access to the Product_Group_vod object.
Solution:
- Assign the product to the user through My Setup Page.
- Grant Read FLS permission to the Detail Group field of the Metrics Configuration object. See Set Field Permissions in Permission Sets and Profiles.
- Be sure that the Detail Groups and Topics are tied properly to Product Groups.
- The API Name and the Record Label name for the Account Type that a Metric is tied to should match exactly.
- Grant the user Read access to the Product_Group_vod object.
Related Documentation:
CRM Help Documentation: Creating Product-Specific Metric Configurations