Overview:
When users create a survey target by the New button of the related list on the Account page, the error "This survey has not been assigned to any channels" happens when saving the survey target online.
Root Cause:
The error is because the value of Channels_vod__c in the survey target is empty. Veeva logic copies the value of Channels_vod__c from Survey to Survey Target only if using the New Survey Target button, but the default New button does not.
Solution:
Replacing the New button with the New Survey Target button from the survey target related list of the Account page.
Related Documentation:
CRM Help Documentation: Configuring Surveys