Overview:
Upon running a Mass Assignment job, SESSION_TIMEOUT errors can be seen in the related logfile. This issue may manifest in a way that there are 0 Rows Processed, 0 failures, and the Download log still contains rows of a particular job. In this case, in the backend the job fails with an invalid session SFDC related error.
Root Cause:
The issue is caused by the fact that the CRM User - commonly System Administrators - who originally started the job, loses its SFDC Session. This typically happens when the CRM User logs out of Veeva CRM.
Solution:
Be sure not to log out with this CRM User while the Mass Assignment job is running. Also be sure to stay on the Territory Utilities tab. It is strongly advised to have a dedicated CRM System Administrator user for running the Mass Assignment job.
Related Documentation:
Salesforce Documentation:
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.